media URLs not displaying in entities string

Home Forums Basic setup media URLs not displaying in entities string

This topic contains 3 replies, has 2 voices, and was last updated by  mhawksey 2 months, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #990

    desait
    Participant

    Hi. I have a problem with certain tweets that have embedded tweets. Generally these tweets have a “media_url” entry in the entities string, but in tweets that I have collected this component does not exist in the entity string despite the tweet having a picture. I have noticed that in such cases, the raw text of the tweet has been truncated or is filled with gibberish characters (&*&#(!).

    Do these 2 observations have any relation to one another? Is one the cause and the other an effect? Is there a way to resolve both observations so that the data collected remains pure and complete?

    Thank you.

    #991

    mhawksey
    Keymaster

    Hi – so it appears Twitter made some changes to their api I while back that I missed. Your problem sounds similar to this thread https://twittercommunity.com/t/truncated-text-and-media-entities-not-returned/74358/3 . I’ve implemented the change referenced in that post. This will however only work on new copies of the template. All is not lost as from TAGS version 6.1.2 there is a feature to build archives from a column of Twitter ID strings. To rebuild your archive with all the data

        Take a copy of TAGS V6.1 from https://tags.hawksey.info/get-tags/
        Add a sheet called ID and copy/paste your id_str column from your existing Archive sheet
        From the TAGS menu select TAGS > Build archive from Tweet IDs

    If you wish to continue collecting tweets the Readme/Setting sheet can be setup as per your old archive and the Archive sheet will continue appending new tweets as before

    #1005

    desait
    Participant

    Thanks, but there are 2 errors that I am receiving when using TAGS v6.1.3.

    1__When I use TAGS 6.1.3, I can download tweets but cannot see the text. Column C (text) is completely empty. All other columns are populated with data

    2__when I try to “Build Archive from Tweet IDs”, I get the following error message: Type Error: Cannot set property “tweet_mode” of undefined to “extended”

    What do you think I’m doing wrong?

    Link to document: https://docs.google.com/spreadsheets/d/1T4HzRmt-UBh-xL4i9u12QrkeX7kCeF-rQc6xxZNbQrM/edit?usp=sharing

    Thanks.

    • This reply was modified 2 months, 3 weeks ago by  desait.
    #1007

    mhawksey
    Keymaster

    Hi – there was an issue with v6.1.3 and you need the latest version v6.1.4 to have the column C populated.

    [There was also an issue with the Build Archive from Tweet IDs also fixed in v6.1.4]

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Posted in