English only tweets

Home Forums TAGSExplorer Questions/Issues English only tweets

Tagged: ,

This topic contains 7 replies, has 2 voices, and was last updated by  mhawksey 3 months, 4 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #937

    stefano
    Participant

    Hello just a couple of newbie questions.

    I have been looking in the forum but have not find answers:

    – is there a filter to collect only tweets in English (or other languages)?

    – I set one of my sheet to collect tweets every hour, but I get this error “TypeError: Cannot call method “replace” of undefined. (line 318, file “Code”, project “TAGS”)” ..any idea how I can fix this?

    Many thanks for the help

    S.

    #938

    mhawksey
    Keymaster

    Hi,

    To add a language filter with your sheet open select Tools > Script editor. In the code you’ll see an example advanced search parameter declaration

    //var advParams = {“geocode”: “40.714353,-74.005973,30mi”};

    after this add a new line
    var advParams = {“lang”: “en”};

    Save the script and when it runs it should filter new results in English. Note however that this in not 100% accurate and last time a I looked based on the users preferred language setting for using twitter.com

    Re: the error have you changed the name of the Readme/Settings sheet or in the period set in B13 not one of the following: default,-1 days,-2 days,-3 days,-4 days,-5 days,-6 days,-7 days

    #939

    stefano
    Participant

    Cheers mhawksey

    so when I paste the line in the script and save I get an error “Illegal character”. (sorry I am bit numb with coding).

    As for the error, do you mean I should change B13 from default to one of the other values?

    thanks

    #940

    mhawksey
    Keymaster

    sorry the forum displays code wrong … this should be better

    var advParams = {"lang": "en"};

    if B13 is ‘default’ it must be something else. Have you changes any of the sheet names?

    • This reply was modified 3 months, 4 weeks ago by  mhawksey.
    #942

    stefano
    Participant

    Cheers again 🙂

    I get “Invalid Property ID” now.

    * I changed the name of the sheet from the original one if that’s what you mean.
    I now set from default to something else, I will see if it works

    thanks

    #943

    mhawksey
    Keymaster

    Renaming the sheets in the template will break the script 🙂

    #944

    stefano
    Participant

    OK I see (sorry I may look like a bit confused), I did not rename the internal sheets, just the main name of TAGS (as it was suggested when I downloaded it).

    I changed default to another value, but still get the alert that the script isn’t working

    #945

    mhawksey
    Keymaster

    not sure what’s wrong – feel free to share with m.hawksey [at] gmail.com

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Posted in